NuCore Case Problems

Support questions and answer and latest software.
Post Reply
AddictedToEMs
member
Posts: 7
Joined: Mon Oct 25, 2010 8:39 pm

NuCore Case Problems

Post by AddictedToEMs » Mon Oct 25, 2010 9:01 pm

Guys, I bought the new case at Terry's Expo weekend, came home and started the assembly process. The standoffs are too short. My motherboard can squeeze in a little low, but the ArcadeVGA video card won't seat because the mb is sitting too low. I thought about using washers, but I dont want to short out the motherboard. any suggestions?

Scott

User avatar
Chuck
Site Admin
Posts: 1547
Joined: Wed Mar 28, 2007 3:34 pm
Location: Michigan
Contact:

Re: NuCore Case Problems

Post by Chuck » Mon Oct 25, 2010 9:24 pm

Scott,

We just became aware of this issue and here's a quick background and two solutions. When we tested the case we used a few different cards and they all fit. We just purchased a new arcade VGA card (newer version) and found it's a little over a 16th too short. After a little further investigation we found the length of that backplane card is slightly shorter than an average card (but still within spec.) And our case is slightly higher. Add the two together and it doesn't fit. The permanent solution is we are going to have new backplane pieces rush manufactured for the AVGA cards. Every person who buys the new Nucore case will get one with the case (we'll ship yours to you no cost.) We're working with the metal shop to try and get a date on this and we're hoping they can do it in about a week. In the meantime you can bend the top tab on the card up and re-bend it slightly higher than before as a temporary solution. We've tried this and it does work.

We are still waiting on a delivery date from the metal shop. Hopefully we'll hear in a couple of days. That's when we were going to announce this. Sorry if it caused you any inconvenience and we will certainly remedy the situation.

AddictedToEMs
member
Posts: 7
Joined: Mon Oct 25, 2010 8:39 pm

Re: NuCore Case Problems

Post by AddictedToEMs » Mon Oct 25, 2010 9:29 pm

Thanks for the quick reply - glad to hear it wasn't just me.

Post Reply