machine keeps rebooting

Please post all tournament mode/networking questions or information here.
Post Reply
ErikvS
member
Posts: 26
Joined: Wed Oct 13, 2010 3:14 pm

machine keeps rebooting

Post by ErikvS » Tue Dec 14, 2010 2:57 pm

I need some help, installed the 2.0 version and went through all the steps in the manual.
However my machine reboots everytime it wants to start RFM.
So everything loads fine, see the new loading screen then after the 'old' white screen it reboots.
Funny thing is that my machine also used to do this with the old mainboard and prism card with 1.8 RFM update ...
The reboot does not happen when my network cable is not plugged in though.
I have a working ethernet config on the machine, I can ping to any website also forwarding udp 2069 and 2070 to my pinball machine
Is there something else I can check?

I assume we don't need to enter subnet on the p2k communication settings?

User avatar
Chuck
Site Admin
Posts: 1547
Joined: Wed Mar 28, 2007 3:34 pm
Location: Michigan
Contact:

Re: machine keeps rebooting

Post by Chuck » Tue Dec 14, 2010 4:18 pm

First unplug your ethernet cable and turn the tournament mode off (disable it in the WMS diags) so it doesn't keep rebooting. Next verify you have all the correct settings exactly as it says in the install guide. Also don't enter ip's for anything other than the machine 1.0.0.1 and the tournament server 1.0.0.4. Those settings are also correct for everyone no matter what your ip is.

ErikvS
member
Posts: 26
Joined: Wed Oct 13, 2010 3:14 pm

Re: machine keeps rebooting

Post by ErikvS » Tue Dec 14, 2010 4:58 pm

I did all the things from the install guide.
The only thing is that I cannot start firefox because that one was removed in my initial install during the upgrade process as I wrote in another post earlier.
Is there any logfile I can check?
Isn't this a memory problem?
I understood that the original config needed at least 8mb or more ram to work with 1.8...
I can check to see what happens with EP1 in tournament mode

User avatar
Chuck
Site Admin
Posts: 1547
Joined: Wed Mar 28, 2007 3:34 pm
Location: Michigan
Contact:

Re: machine keeps rebooting

Post by Chuck » Tue Dec 14, 2010 6:19 pm

You can check the log files by running the update procedure with a blank usb stick. It copies all of the log files to the stick.

As far as the memory goes the issue you are talking about didn't cause reboots like you're seeing as far as I know it was a problem when you had lots of pictures in a high score list. Either way we added additional memory to the virtual system to solve any memory issues.

After you grab the log files post them here and I will take a look.

ErikvS
member
Posts: 26
Joined: Wed Oct 13, 2010 3:14 pm

Re: machine keeps rebooting

Post by ErikvS » Wed Dec 15, 2010 3:21 am

Here are some of the log files.
I attached the last 6, scanning through some of them I see some error messages and warning messages.
Something else, would it be possible to save the config of the games to USB?
So if the ubuntu machine crashes or you want to start from scratch it is possible to keep all your old settings and high scores? You need the option to load them in too :)
Attachments
logs.zip
(10.56 KiB) Downloaded 327 times

User avatar
Chuck
Site Admin
Posts: 1547
Joined: Wed Mar 28, 2007 3:34 pm
Location: Michigan
Contact:

Re: machine keeps rebooting

Post by Chuck » Wed Dec 15, 2010 12:49 pm

According to your log files the machine is unable to make a connection to the server. It could be anything from your internet connection, a firewall somewhere, or something local on that machine. You need to get firefox installed and test your internet connection that way. If that works I would check your router settings. If all of that fails you could take the nucore computer somewhere else that has an internet connection and test it there. To run it without being connected to the machine:

1) Boot it up.
2) Exit from the emulator (F1)
3) Login root/nucore
4) cd /nucore/bin
5) ./run nucore rfm_15 -fullscreen

If the server comes up here you know it's your internet connection.

ErikvS
member
Posts: 26
Joined: Wed Oct 13, 2010 3:14 pm

Re: machine keeps rebooting

Post by ErikvS » Wed Dec 15, 2010 4:06 pm

Good news,
don't know why but it works now. I removed my computer from the pinball machine
hooked it up to a different cable on my switch in my room. Just played around and made sure everything works. Then I hooked it up again in the pinball machine
all my settings were reset (can you explain why?)
But now I am connected. Will play 1 game and then quickly turn it off as my kids are all asleep :)

User avatar
Chuck
Site Admin
Posts: 1547
Joined: Wed Mar 28, 2007 3:34 pm
Location: Michigan
Contact:

Re: machine keeps rebooting

Post by Chuck » Wed Dec 15, 2010 4:36 pm

Good to hear. Make sure the jumper on your usb board is set on (J3) If this isn't jumpered you will lose your settings when the machine turns off. It will keep your settings if you reload also to answer your earlier question.

ErikvS
member
Posts: 26
Joined: Wed Oct 13, 2010 3:14 pm

Re: machine keeps rebooting

Post by ErikvS » Wed Dec 15, 2010 4:39 pm

Cool, I believe it is not jumpered will do that asap :)
Great to see the tournament mode working, one of the main reasons for me to go to nucore (apart from easier playfield switching and the much better performance)

Post Reply